非常准的指标 趋势拐点源码-仟家信公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 外汇现货>> 仟家信等>> 仟家信公式>>正文内容

365bet送体验金

非常准的指标 趋势拐点源码:

VAR1:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),25);
VAR2:=HIGH-REF(HIGH,1);
VAR3:=REF(LOW,1)-LOW;
VAR4:=SUM(IF(VAR2>0 AND VAR2>VAR3,VAR2,0),25);
VAR5:=SUM(IF(VAR3>0 AND VAR3>VAR2,VAR3,0),25);
VAR6:=VAR4*100/VAR1;
VAR7:=VAR5*100/VAR1;
VAR8:=MA(ABS(VAR7-VAR6)/(VAR7+VAR6)*100,15);
VAR9:=(VAR8+REF(VAR8,15))/2;
A:=(VAR7>VAR6 AND VAR7>25 AND VAR6<25);
B:ZIG(3,50/5)*100,colorwhite;
G:MA(B,2),coloryellow;
D:=CROSS(B,G)*1000,colorred;
W:=CROSS(G,B)*1000,colorblue;
E:=REF(INDEXC,1);
F:=SMA(MAX(INDEXC-E,0),3,1)/SMA(ABS(INDEXC-E),3,1);
VAR10:=F AND F<8;
VAR11:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR12:=SMA(VAR11,3,1);
VAR13:=SMA(VAR12,3,1);
VAR14:=VAR13 AND VAR13<20;
MM:=A AND D AND VAR10 AND VAR14 ;
DRAWTEXT(W=1000,B*1.05,'拐下' ),COLOR00FF00;
DRAWTEXT(D=1000,B*1.05,'拐上'),colorred;

 

源码解析:

VAR1赋值:最高价-最低价和最高价-昨收的绝对值的较大值和最低价-昨收的绝对值的较大值的25日累和
VAR2赋值:最高价-昨日最高价
VAR3赋值:昨日最低价-最低价
VAR4赋值:如果VAR2>0ANDVAR2>VAR3,返回VAR2,否则返回0的25日累和
VAR5赋值:如果VAR3>0ANDVAR3>VAR2,返回VAR3,否则返回0的25日累和
VAR6赋值:VAR4*100/VAR1
VAR7赋值:VAR5*100/VAR1
VAR8赋值:VAR7-VAR6的绝对值/(VAR7+VAR6)*100的15日简单移动平均
VAR9赋值:(VAR8+15日前的VAR8)/2
A赋值:(VAR7>VAR6 AND VAR7>25 AND VAR6<25)
输出B:收盘价50/5%的之字转向*100,画白色
输出G:B的2日简单移动平均,画黄色
D赋值:B上穿G*1000,画红色
W赋值:G上穿B*1000,画蓝色
E赋值:昨收
F赋值:收盘价-E和0的较大值的3日[1日权重]移动平均/收盘价-E的绝对值的3日[1日权重]移动平均
VAR10赋值:F AND F<8
VAR11赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
VAR12赋值:VAR11的3日[1日权重]移动平均
VAR13赋值:VAR12的3日[1日权重]移动平均
VAR14赋值:VAR13 AND VAR13<20
MM赋值:A AND D AND VAR10 AND VAR14
当满足条件W=1000时,在B*1.05位置书写文字,COLOR00FF00
当满足条件D=1000时,在B*1.05位置书写文字,画红色
 

 

如果以上指标公式不适用于您常用的行情软件

或者您想改编成选股公式,以便快速选出某种形态个股的话,

可以联系我们相关技术人员 QQ: 262069696  点击在线交流进行 有偿 改编!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容