现货稳赚趋势指标源码-仟家信公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 外汇现货>> 仟家信等>> 仟家信公式>>正文内容

365bet送体验金

现货稳赚趋势指标完整源码如下:

 

Var1:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;

Var2:=SMA(Var1,3,1);

Var3:=SMA(Var2,3,1);

Var4:=3*Var2-2*Var3;

Var5:=LLV(LOW,5);

Var6:=HHV(HIGH,5);

Var7:=EMA((CLOSE-Var5)/(Var6-Var5)*100,4)*2;

Var8:=EMA(0.667*REF(Var7,1)+0.333*Var7,2);

Var9:=3*Var7-2*Var8;

VarA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);

VarB:=POW(MA(LOW,5),2)+MA(LOW,5);

VarC:=POW(MA(HIGH,5),2)+MA(HIGH,5);{来源 grahamobil.com }

VarD:=(VarA-LLV(VarB,64))/(HHV(VarC,64)-LLV(VarB,64))*150+65-10;

VarE:=SMA(VarD,3,1)*1.5-100;

VarF:=SMA(VarE,3,1);

Var10:=3*VarE-2*VarF;

Var11:=(HIGH+LOW+CLOSE*2)/4;

Var12:=EMA(Var11,13);

Var13:=STD(Var11,13);

Var14:=(Var11-Var12)*100/Var13;

Var15:=EMA(Var14,5);

Var17:=EMA(Var15,13)+200-100;

Var18:=EMA(Var17,10);

Var19:=3*Var17-2*Var18;

Var1A:=Var2+Var7+VarE+Var17;

Var1B:=Var3+Var8+VarF+Var18;

Var1C:=Var4+Var9+Var10+Var19;

Var1D:=(HIGH+LOW+CLOSE)/3;

Var20:=(Var1D-MA(Var1D,34))/(0.015*AVEDEV(Var1D,34));

Var21:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);

Var22:=(HIGH+LOW+CLOSE+Var1D)/4;

Var23:=EMA(Var22,24);

Var24:=STD(Var22,24);

Var25:=(Var22-Var23)/Var24*100;

Var26:=(Var1D-MA(Var1D,24))/(0.015*AVEDEV(Var1D,24));

Var27:=EMA(Var25,5);

Var2A:=((Var27+Var26+Var20)/3+165)/4;

Var2B:=(EMA(EMA(EMA(Var2A,15),10),5)-25)*2+Var21;

Var2C:=(Var1A+Var1B+Var1C*30)/32/5-15;

Var2D:=EMA(Var2C,13);{13}

Var2E:=(Var2A+Var2C)/2/1.1;  

Var28:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

Var29:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

Var30:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

Var31:=REF(CLOSE,1);

Var32:=SMA(MAX(CLOSE-Var31,0),5,1)/SMA(ABS(CLOSE-Var31),5,1)*100;

Var33:=(HIGH+LOW+CLOSE)/3;

Var34:=(Var33-MA(Var33,14))/(0.015*AVEDEV(Var33,14));

DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.grahamobil.com '),COLORRED;
DRAWTEXT_FIX(C>O,1,1,0,' cxh99.com 程序化交易模型'),COLORRED;

超短:EMA(Var2E,3),colorred ;

短线:EMA(超短,5),colorwhite;

趋势线:EMA((Var2B+Var2D)/2,2) ,coloryellow;

 

 

 

 

源码解析:

VAR1赋值:(收盘价-80日内最低价的最低值)/(80日内最高价的最高值-80日内最低价的最低值)*200
VAR2赋值:VAR1的3日[1日权重]移动平均
VAR3赋值:VAR2的3日[1日权重]移动平均
VAR4赋值:3*VAR2-2*VAR3
VAR5赋值:5日内最低价的最低值
VAR6赋值:5日内最高价的最高值
VAR7赋值:(收盘价-VAR5)/(VAR6-VAR5)*100的4日指数移动平均*2
VAR8赋值:0.667*昨日VAR7+0.333*VAR7的2日指数移动平均
VAR9赋值:3*VAR7-2*VAR8
VARA赋值:收盘价的5日简单移动平均的2乘幂+收盘价的5日简单移动平均
VARB赋值:最低价的5日简单移动平均的2乘幂+最低价的5日简单移动平均
VARC赋值:最高价的5日简单移动平均的2乘幂+最高价的5日简单移动平均
VARD赋值:(VARA-64日内VARB的最低值)/(64日内VARC的最高值-64日内VARB的最低值)*150+65-10
VARE赋值:VARD的3日[1日权重]移动平均*1.5-100
VARF赋值:VARE的3日[1日权重]移动平均
VAR10赋值:3*VARE-2*VARF
VAR11赋值:(最高价+最低价+收盘价*2)/4
VAR12赋值:VAR11的13日指数移动平均
VAR13赋值:VAR11的13日估算标准差
VAR14赋值:(VAR11-VAR12)*100/VAR13
VAR15赋值:VAR14的5日指数移动平均
VAR17赋值:VAR15的13日指数移动平均+200-100
VAR18赋值:VAR17的10日指数移动平均
VAR19赋值:3*VAR17-2*VAR18
VAR1A赋值:VAR2+VAR7+VARE+VAR17
VAR1B赋值:VAR3+VAR8+VARF+VAR18
VAR1C赋值:VAR4+VAR9+VAR10+VAR19
VAR1D赋值:(最高价+最低价+收盘价)/3
VAR20赋值:(VAR1D-VAR1D的34日简单移动平均)/(0.015*VAR1D的34日平均绝对偏差)
VAR21赋值:以成交量(手)/当前流通股本(手)为权重成交额(元)/成交量(手)/100的动态移动平均
VAR22赋值:(最高价+最低价+收盘价+VAR1D)/4
VAR23赋值:VAR22的24日指数移动平均
VAR24赋值:VAR22的24日估算标准差
VAR25赋值:(VAR22-VAR23)/VAR24*100
VAR26赋值:(VAR1D-VAR1D的24日简单移动平均)/(0.015*VAR1D的24日平均绝对偏差)
VAR27赋值:VAR25的5日指数移动平均
VAR2A赋值:((VAR27+VAR26+VAR20)/3+165)/4
VAR2B赋值:(VAR2A的15日指数移动平均的10日指数移动平均的5日指数移动平均-25)*2+VAR21
VAR2C赋值:(VAR1A+VAR1B+VAR1C*30)/32/5-15
VAR2D赋值:VAR2C的13日指数移动平均
VAR2E赋值:(VAR2A+VAR2C)/2/1.1
VAR28赋值:(收盘价-收盘价的6日简单移动平均)/收盘价的6日简单移动平均*100
VAR29赋值:(收盘价-收盘价的12日简单移动平均)/收盘价的12日简单移动平均*100
VAR30赋值:(收盘价-收盘价的24日简单移动平均)/收盘价的24日简单移动平均*100
VAR31赋值:昨收
VAR32赋值:收盘价-VAR31和0的较大值的5日[1日权重]移动平均/收盘价-VAR31的绝对值的5日[1日权重]移动平均*100
VAR33赋值:(最高价+最低价+收盘价)/3
VAR34赋值:(VAR33-VAR33的14日简单移动平均)/(0.015*VAR33的14日平均绝对偏差)
输出超短:VAR2E的3日指数移动平均,画红色
输出短线:超短的5日指数移动平均,画白色
输出趋势线:(VAR2B+VAR2D)/2的2日指数移动平均 ,画黄色

 

 

如果以上指标公式不适用于您常用的行情软件

或者您想改编成选股公式,以便快速选出某种形态个股的话,

可以联系我们相关技术人员 QQ: 262069696  点击在线交流进行 有偿 改编!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容