倚天逃出苦海指标-倚天版公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 外汇现货>> 倚天财经>> 倚天版公式>>正文内容

365bet送体验金

AA:MA(WINNER(C*0.95)*100,3),COLORYELLOW;
AA,stick,COLORYELLOW,linethick2;
Var1:=1/WINNER(CLOSE);
Var2:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
Var3:=100-ABS(Var2);
Var4:=3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
Var5:=3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
Var6:=100-Var5;
Var7:=100-Var4;
Var8:=MA(WINNER(CLOSE*0.95)*100,3);
Var9:=IF(Var1>5,IF(Var1<100,Var1,Var3-10),0);
VarA:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VarB:=SMA(VarA,3,1);
VarC:=SMA(VarB,3,1);
探索: EMA(3*VarB-2*VarC,3),colorwhite;
主力: (-1)*(EMA(Var7,1)-50)+50,COLORYELLOW,linethick2;
Z1: MA(主力,9),COLORRED,linethick2;
VarD:=(-1)*(EMA(Var7,1)-50)+50;
VarE:=(-1)*(EMA(Var7,12)-50)+50;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
天涯:if(rsi1>93 or (AA>90 and rsi1>80),80,100),;
海角: 0,colorgreen;
苦海:EMA(100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14)),6),LINESTICK,;
ZS: MA(探索,3),COLORYELLOW;
ZM: MA(MA(探索,3),3),COLORGREEN; 

 

源码解析:

输出AA:以收盘价*0.95计算的获利盘比例*100的3日简单移动平均,画黄色
AA,STICK,画黄色,线宽为2
VAR1赋值:1/以收盘价计算的获利盘比例
VAR2赋值:(收盘价-收盘价的13日简单移动平均)/收盘价的13日简单移动平均*100
VAR3赋值:100-VAR2的绝对值
VAR4赋值:3*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均-2*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
VAR5赋值:3*(开盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均-2*(开盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
VAR6赋值:100-VAR5
VAR7赋值:100-VAR4
VAR8赋值:以收盘价*0.95计算的获利盘比例*100的3日简单移动平均
VAR9赋值:如果VAR1>5,返回如果VAR1<100,返回VAR1,否则返回VAR3-10,否则返回0
VARA赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
VARB赋值:VARA的3日[1日权重]移动平均
VARC赋值:VARB的3日[1日权重]移动平均
输出探索: 3*VARB-2*VARC的3日指数移动平均,画白色
输出主力: (-1)*(VAR7的1日指数移动平均-50)+50,画黄色,线宽为2
输出Z1: 主力的9日简单移动平均,画红色,线宽为2
VARD赋值:(-1)*(VAR7的1日指数移动平均-50)+50
VARE赋值:(-1)*(VAR7的12日指数移动平均-50)+50
赋值: 昨收
RSI1赋值:收盘价-LC和0的较大值的6日[1日权重]移动平均/收盘价-LC的绝对值的6日[1日权重]移动平均*100
输出天涯:如果RSI1>93OR(AA>90ANDRSI1>80),返回80,否则返回100,
输出海角: 0,画绿色
输出苦海:100*(14日内最高价的最高值-收盘价)/(14日内最高价的最高值-14日内最低价的最低值)的6日指数移动平均,LINESTICK,
输出ZS: 探索的3日简单移动平均,画黄色
输出ZM: 探索的3日简单移动平均的3日简单移动平均,画绿色
 
 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 262069696  点击在线交流进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容