这些IF语句要怎么改写?-开拓者知识 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 期货公式>> 交易开拓者(TB)>> 开拓者知识>>正文内容

365bet送体验金

  • 咨询内容: //------------------------------------------------------------------------
    Params
        Numeric K1(.5);
            Numeric K2(.5);
            Numeric MDAY(1);
            Numeric NDAY(1);
    VARS
            Numeric SELLRANGE(0);
        Numeric BUYTRIG(0);
            Numeric SELLTRIG(0);
        Numeric HH(0);
            Numeric LL(0);
            Numeric HC(0);
            Numeric LC(0);


            If(CURRENTBAR>1)
    {
    HH:=HHV(HIGH,MDAY);
    HC:=HHV(CLOSE,MDAY);
    LL :=LLV(LOW,MDAY);
    LC:=LLV(CLOSE,MDAY);
    }
      else If ((HH - LC) >= (HC - LL))
      {
      SELLRANGE = HH - LC;
      }
      END
      ELSE
    {SELLRANGE = HC - LL;
    }
    END;

    HH:=HHV(HIGH,NDAY);
    HC:=HHV(CLOSE,NDAY);
    LL:=LLV(LOW,NDAY);
    LC:=LLV(CLOSE,NDAY);

    IF (HH - LC) >= (HC - LL) THEN BEGIN
    BUYRANGE = HH - LC;
    END ELSE BEGIN
    BUYRANGE = HC - LL;
    END;

    BUYTRIG = K1*BUYRANGE;
    SELLTRIG = K2*SELLRANGE;

    IF MARKETPOSITION = 0 THEN BEGIN
    BUY AT OPEN OF NEXT BAR + BUYTRIG STOP;
    SELL AT OPEN OF NEXT BAR - SELLTRIG STOP;
    END;

    IF MARKETPOSITION = -1 THEN BEGIN
    BUY AT OPEN OF NEXT BAR + BUYTRIG STOP;
    END;

     

     来源:grahamobil.com

  • TB技术人员: if是一样的啊。。
    TB的if后条件需要使用()括号括起来

     

  • TB客服: 多谢

     

  • 网友回复: 我上面的语句  IF后面是加括号的呀

     

  • 网友回复:
  • yulei2530 发表于 2018-5-6 08:10
    我上面的语句  IF后面是加括号的呀

    你上面的有一部分if后是没有加括号的,关键是语法都不是TB,不可兼容的。

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容